What’s Vulnerable › Vulnerabilities
CVE-2026-109658: Frappe ERPNext before 15.115.0 Missing Authorization on Endpoints
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-13
- Weakness: CWE-862
Description
Frappe ERPNext before 15.115.0 and 16.x before 16.26.0 contains a missing authorization vulnerability in which certain endpoints fail to enforce proper authorization checks. Authenticated users can call these endpoints to read data, including personal data, beyond what their assigned role permits.
Affected products
- frappe erpnext: before 15.115.0; from 16.0.0-beta.1 before 16.26.0 — fixed in 15.115.0, 16.26.0
How to fix
Upgrade to a fixed version: frappe erpnext 15.115.0, 16.26.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/erpnext/security/advisories/GHSA-gq9h-847p-h692
- https://www.vulncheck.com/advisories/frappe-erpnext-before-15.115.0-missing-authorization-on-endpoints
Get alerted when CVE-2026-109658 or the next vulnerability affects your stack