What’s Vulnerable › Vulnerabilities
CVE-2026-109667: Frappe ERPNext before 15.111.0 Privilege Escalation via Unauthorized Record Creation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-14
- Weakness: CWE-269
Description
Frappe ERPNext before 15.111.0 and 16.x before 16.22.0 contains a privilege escalation vulnerability in a record-creation endpoint that takes the record type from the request and inserts the record with permission checks disabled. Any authenticated user, including one holding no operational role, can supply a privileged record type to create privileged accounts and take full control of the site.
Affected products
- frappe erpnext: before 15.111.0; from 16.0.0-beta.1 before 16.22.0 — fixed in 15.111.0, 16.22.0
How to fix
Upgrade to a fixed version: frappe erpnext 15.111.0, 16.22.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/erpnext/security/advisories/GHSA-x635-wr4c-7345
- https://www.vulncheck.com/advisories/frappe-erpnext-before-15.111.0-privilege-escalation-via-unauthorized-record-creation
Get alerted when CVE-2026-109667 or the next vulnerability affects your stack