What’s Vulnerable › Vulnerabilities
CVE-2026-109670: Frappe ERPNext before 15.110.0 Stored XSS via Item Record Name
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-18
- Weakness: CWE-79
Description
Frappe ERPNext before 15.110.0 and 16.x before 16.21.0 contains a stored cross-site scripting vulnerability caused by record names being rendered without escaping. Attackers with write access to item master data can store malicious script in a record name that executes in the browser of any operator who opens the affected page.
Affected products
- frappe erpnext: before 15.110.0; from 16.0.0-beta.1 before 16.21.0 — fixed in 15.110.0, 16.21.0
How to fix
Upgrade to a fixed version: frappe erpnext 15.110.0, 16.21.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/erpnext/security/advisories/GHSA-m6x2-278g-pv2g
- https://www.vulncheck.com/advisories/frappe-erpnext-before-15.110.0-stored-xss-via-item-record-name
Get alerted when CVE-2026-109670 or the next vulnerability affects your stack