What’s Vulnerable › Vulnerabilities
CVE-2026-109869: undici vulnerable to Denial of Service via unhandled error on excessive content-encodings
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-15 · updated 2026-10-19
- Weakness: CWE-248
Description
undici is an HTTP client library for Node.js. In versions 6.23.0 through 6.29.0, 7.18.0 through 7.30.0, and 8.0.0 through 8.12.1, its fetch() implementation crashes the Node.js process when a malicious server returns a response with more than five content codings and closes the connection before sending the body. undici rejects such responses because of a content-encoding limit, but it created the internal response stream before that check and returned without attaching an error listener or aborting the request, so the early close surfaces a content-length mismatch on the orphaned stream, which Node.js treats as an unhandled error and terminates the process. A remote, unauthenticated server can trigger this with a single response, even when the application correctly catches the fetch() rejection, resulting in a denial of service. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, and users should upgrade to one of those versions or later. There is no workaround.
Affected products
- undici: from 6.23.0 before 6.29.1; from 7.18.0 before 7.30.1; from 8.0.0 before 8.12.2 — fixed in 6.29.1, 7.30.1, 8.12.2
- Npm Undici: from 6.23.0 before 6.29.1; from 7.18.0 before 7.30.1; from 8.0.0 before 8.12.2 — fixed in 6.29.1, 7.30.1, 8.12.2
How to fix
Upgrade to a fixed version: undici 6.29.1, 7.30.1, 8.12.2; Npm Undici 6.29.1, 7.30.1, 8.12.2. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/nodejs/undici/security/advisories/GHSA-xjj6-f33q-929c
Get alerted when CVE-2026-109869 or the next vulnerability affects your stack