What’s Vulnerable › Vulnerabilities
CVE-2026-109924: undici vulnerable to Denial of Service via unbounded memory in the EventSource parser
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-15 · updated 2026-10-19
- Weakness: CWE-770
Description
undici is an HTTP client library for Node.js. In versions 6.5.0 through 6.29.0, 7.0.0 through 7.30.0, and 8.0.0 through 8.12.1, its EventSource client can be driven to exhaust process memory by a malicious or compromised Server-Sent Events peer. By sending millions of tiny completed data fields with no blank event separator, or a single unfinished line split across many chunks, the parser retains a growing amount of per-field and per-chunk state that the byte-based maxEventSize and maxResponseSize limits do not bound, and because maxResponseSize is enforced on the compressed body before decompression, a small compressed response can expand into enough retained memory to terminate the process. An application only needs to maintain an EventSource connection to an untrusted peer, which controls only the response, and availability is the only impact. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, which bound the retained parser state independently of the byte limits, and users should upgrade to one of those versions or later. There is no workaround.
Affected products
- undici: from 6.5.0 before 6.29.1; from 7.0.0 before 7.30.1; from 8.0.0 before 8.12.2 — fixed in 6.29.1, 7.30.1, 8.12.2
- Npm Undici: from 6.5.0 before 6.29.1; from 7.0.0 before 7.30.1; from 8.0.0 before 8.12.2 — fixed in 6.29.1, 7.30.1, 8.12.2
How to fix
Upgrade to a fixed version: undici 6.29.1, 7.30.1, 8.12.2; Npm Undici 6.29.1, 7.30.1, 8.12.2. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/nodejs/undici/security/advisories/GHSA-4qv8-2p9j-2685
Get alerted when CVE-2026-109924 or the next vulnerability affects your stack