What’s Vulnerable › Vulnerabilities
CVE-2026-109932: undici WebSocket client vulnerable to Denial of Service via unbounded automatic PONG buffering
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-15 · updated 2026-10-19
- Weakness: CWE-400
Description
undici is an HTTP client library for Node.js. In versions 5.15.0 through 6.29.0, 7.0.0 through 7.30.0, and 8.0.0 through 8.12.1, its WebSocket client, including the bundled WebSocket exposed by Node.js, can be driven to exhaust process memory by a malicious or compromised WebSocket server. For every PING frame received, the client automatically writes a PONG response and ignores the backpressure signal from the socket write, so a server that streams small PING frames while never reading the client's PONGs makes the outbound write queue and heap grow without bound until the Node.js process runs out of memory and terminates. The attack is remote and unauthenticated, needs only a normal WebSocket connection, and is asymmetric, since small inbound PINGs produce a much larger retained outbound queue, with availability the only impact. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, which pause WebSocket frame parsing when the automatic PONG response hits socket backpressure and resume on drain, bounding the outbound queue, and users should upgrade to one of those versions or later. There is no workaround.
Affected products
- undici: from 5.15.0 before 6.29.1; from 7.0.0 before 7.30.1; from 8.0.0 before 8.12.2 — fixed in 6.29.1, 7.30.1, 8.12.2
- Npm Undici: from 5.15.0 before 6.29.1; from 7.0.0 before 7.30.1; from 8.0.0 before 8.12.2 — fixed in 6.29.1, 7.30.1, 8.12.2
How to fix
Upgrade to a fixed version: undici 6.29.1, 7.30.1, 8.12.2; Npm Undici 6.29.1, 7.30.1, 8.12.2. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/nodejs/undici/security/advisories/GHSA-9fm3-97px-rjf6
Get alerted when CVE-2026-109932 or the next vulnerability affects your stack