What’s Vulnerable › Vulnerabilities
CVE-2026-109934: Otter Blocks 3.1.1 - 3.2.7 - Unauthenticated Non-Public Content Disclosure via REST API
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-23 · updated 2026-10-23
- Weakness: CWE-200
Description
The Otter Blocks WordPress plugin before 3.2.8 does not correctly determine whether a post is publicly readable before returning its data through a REST API endpoint, treating any post with the published status as public, allowing unauthenticated users to read manual excerpts of password-protected posts, the content and titles of non-public post types, and, on WooCommerce sites, coupon codes and their descriptions.
Affected products
- themeisle Otter Blocks – Gutenberg Blocks, Page Builder for Gutenberg Editor & FSE: from 3.1.1 before 3.2.8 — fixed in 3.2.8
How to fix
Upgrade to a fixed version: themeisle Otter Blocks – Gutenberg Blocks, Page Builder for Gutenberg Editor & FSE 3.2.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-109934 or the next vulnerability affects your stack