What’s Vulnerable › Vulnerabilities
CVE-2026-109958: EspoCRM 4.0.0 before 10.0.7 Field-Level Access Bypass via Address-Book Search
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-13 · updated 2026-10-14
- Weakness: CWE-200
Description
EspoCRM 4.0.0 before 10.0.7 contains an improper access control vulnerability that allows authenticated users to read restricted emailAddress values via the address-book search API. Users with record access can query address-book search to obtain email addresses even when Roles restrict the emailAddress field.
Affected products
- espocrm: from 4.0.0 before 10.0.7 — fixed in 10.0.7
How to fix
Upgrade to a fixed version: espocrm 10.0.7. Check the vendor advisory for mitigations.
References
- https://github.com/espocrm/espocrm/security/advisories/GHSA-2cr7-9g4f-8723
- https://www.vulncheck.com/advisories/espocrm-4.0.0-before-10.0.7-field-level-access-bypass-via-address-book-search
Get alerted when CVE-2026-109958 or the next vulnerability affects your stack