What’s Vulnerable › Vulnerabilities
CVE-2026-109960: Froxlor 2.0.0 before 2.3.14 Stored XSS via Customer Theme Value
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-13 · updated 2026-10-13
- Weakness: CWE-79
Description
Froxlor 2.0.0 before 2.3.14 contains a stored cross-site scripting vulnerability that allows authenticated customers to inject HTML and JavaScript by setting a malicious theme value via customer_index.php. Script executes when an administrator views the customer overview with the Theme column enabled, letting attackers abuse the CSRF token to create administrator accounts or change server settings.
Affected products
- froxlor: from 2.0.0 before 2.3.14 — fixed in 2.3.14
How to fix
Upgrade to a fixed version: froxlor 2.3.14. Check the vendor advisory for mitigations.
References
- https://github.com/froxlor/froxlor/security/advisories/GHSA-3jpp-mhvh-rv66
- https://www.vulncheck.com/advisories/froxlor-2.0.0-before-2.3.14-stored-xss-via-customer-theme-value
- https://github.com/froxlor/froxlor/security/advisories/GHSA-3jpp-mhvh-rv66
Get alerted when CVE-2026-109960 or the next vulnerability affects your stack