What’s Vulnerable › Vulnerabilities
CVE-2026-109964: ImageMagick before 7.1.2-33 and 6.9.13-58 Heap Buffer Underwrite in PICT Decoder
- Severity: medium (CVSS 5.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-13 · updated 2026-10-13
- Weakness: CWE-124
Description
ImageMagick before 7.1.2-33 and 6.9.13-58 contains a heap buffer underwrite vulnerability in DecodeImage() in coders/pict.c on 32-bit builds due to pointer arithmetic overflow. Attackers can supply a crafted PICT file with maximized row, column and bytes-per-line values to bypass bounds checks and write up to 128 controlled bytes below the heap buffer, causing crashes or code execution.
Affected products
- ImageMagick: from 7.0.0-0 before 7.1.2-33; before 6.9.13-58 — fixed in 6.9.13-58, 7.1.2-33
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-58, 7.1.2-33. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick
- https://github.com/ImageMagick/ImageMagick/blob/7.1.2-32/coders/pict.c#L503-L540
- https://github.com/ImageMagick/ImageMagick/commit/63dde0cf281383ab69432b88305f7dcd6a8ce900
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-mqmp-r5jh-jx7w
- https://github.com/ImageMagick/ImageMagick6/commit/c18c5d5fb7f1d87ddbe0a02e9d1207c89b24588c
- https://www.vulncheck.com/advisories/imagemagick-before-7.1.2-33-and-6.9.13-58-heap-buffer-underwrite-in-pict-decoder
Get alerted when CVE-2026-109964 or the next vulnerability affects your stack