What’s Vulnerable › Vulnerabilities
CVE-2026-110005: Moghtech Komodo contains an OS command injection vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-13 · updated 2026-10-20
- Weakness: CWE-78
Description
The `periphery` agent's container-management functionality of Komodo version 2.2.0 contains an OS command injection vulnerability. An authenticated low-privileged user with `Execute`, or `Read` plus `Logs`, permission on a managed server can supply shell metacharacters in a container name processed by the `DestroyContainer` or `SearchContainerLog` operations. The container name is interpolated without escaping into a command executed using `sh -c`, allowing arbitrary commands to execute as root on the managed host. This permits a user without Komodo's `Terminal` permission to obtain unrestricted host-level command execution.
Affected products
- Komodo: from 1.19.1 before 2.3.0 — fixed in 2.3.0
How to fix
Upgrade to a fixed version: Komodo 2.3.0. Check the vendor advisory for mitigations.
In the news
References
Get alerted when CVE-2026-110005 or the next vulnerability affects your stack