What’s Vulnerable › Vulnerabilities
CVE-2026-110015: Salon Booking System < 10.31.9 - Administrator Account Creation via CSRF
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-16 · updated 2026-10-16
- Weakness: CWE-352
Description
The Salon Booking System WordPress plugin before 10.31.9 does not correctly verify the authenticity of REST API requests and discards WordPress core's nonce check for cookie-authenticated sessions across the whole REST API, allowing unauthenticated attackers who trick a logged-in administrator into clicking a crafted link to forge requests in that administrator's browser, up to creating a new administrator account.
Affected products
- Salon booking system: before 10.31.9 — fixed in 10.31.9
How to fix
Upgrade to a fixed version: Salon booking system 10.31.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-110015 or the next vulnerability affects your stack