What’s Vulnerable › Vulnerabilities
CVE-2026-110024: @fastify/jwt vulnerable to missing token expiration when per-call options drop global defaults
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-18 · updated 2026-10-20
- Weakness: CWE-613
Description
@fastify/jwt is a JWT utility plugin for Fastify. In versions prior to 10.2.5, the top-level sign and verify methods replace the globally configured defaults with the per-call options instead of merging them, so passing any per-call option silently drops every global default that the call does not restate, including temporal protections such as token expiration and maximum accepted token age. A token signed this way carries no expiration claim and never expires, and verification stops enforcing a configured maximum age, so stale or never-expiring tokens are accepted. The route-level decorators for signing and verifying already merge options and are not affected. The issue is fixed in @fastify/jwt 10.2.5, and users should upgrade to 10.2.5 or later.
Affected products
- @fastify/jwt: before 10.2.5 — fixed in 10.2.5
How to fix
Upgrade to a fixed version: @fastify/jwt 10.2.5. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/fastify/fastify-jwt/security/advisories/GHSA-f5gh-84pj-v2pg
Get alerted when CVE-2026-110024 or the next vulnerability affects your stack