What’s Vulnerable › Vulnerabilities
CVE-2026-110029: Squeeze < 1.8.1 - Subscriber+ Missing Authorization via squeeze_restore_attachment
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-16 · updated 2026-10-16
- Weakness: CWE-862
Description
The Squeeze WordPress plugin before 1.8.1 does not perform a capability check on one of its AJAX actions, allowing authenticated users with a role as low as Subscriber to revert any attachment to its backup copy and to permanently delete that backup and the plugin's generated WebP derivatives, regardless of ownership.
Affected products
- Squeeze: before 1.8.1 — fixed in 1.8.1
How to fix
Upgrade to a fixed version: Squeeze 1.8.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-110029 or the next vulnerability affects your stack