What’s Vulnerable › Vulnerabilities

CVE-2026-1101: Improper Validation of Specified Quantity in Input in GitLab

Description

GitLab has remediated an issue in GitLab EE affecting all versions from 18.2 before 18.8.9, 18.9 before 18.9.5, and 18.10 before 18.10.3 that could have allowed an authenticated user to cause denial of service to the GitLab instance due to improper input validation in GraphQL queries.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.10.3, 18.8.9, 18.9.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-1101 or the next vulnerability affects your stack