What’s Vulnerable › Vulnerabilities

CVE-2026-110264: Integer Overflow or Wraparound in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions from 7.0 before 18.11.13, 19.0 before 19.0.10, 19.1 before 19.1.9, 19.2 before 19.2.9, 19.3 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary code on the GitLab server due to integer overflow when compiling a specially crafted regular expression.

Summary

CVE-2026-110264 is a critical integer overflow in GitLab CE/EE that, under certain conditions, could let an unauthenticated user execute arbitrary code on the GitLab server by compiling a specially crafted regular expression. It affects all versions from 7.0 before 18.11.13, 19.0 before 19.0.10, 19.1 before 19.1.9, 19.2 before 19.2.9, 19.3 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1, with a CVSS score of 10. There is no evidence of active exploitation (not in CISA KEV, SSVC exploitation: none, EPSS 1.0%). Upgrade to 18.11.13, 19.0.10, 19.1.9, 19.2.9, 19.3.6, 19.4.3, or 19.5.1 as applicable.

CVE-2026-110264 هو ثغرة تجاوز صحيح (Integer Overflow) حرجة في GitLab CE/EE قد تسمح، في ظروف معينة، لمستخدم غير مصادق عليه بتنفيذ تعليمات برمجية عشوائية على خادم GitLab عبر ترجمة تعبير نمطي (regular expression) مصمم خصيصًا. تؤثر الثغرة في جميع الإصدارات من 7.0 قبل 18.11.13، و19.0 قبل 19.0.10، و19.1 قبل 19.1.9، و19.2 قبل 19.2.9، و19.3 قبل 19.3.6، و19.4 قبل 19.4.3، و19.5 قبل 19.5.1، بدرجة CVSS تبلغ 10. لا توجد أدلة على استغلال نشط (غير مدرجة في CISA KEV، وSSVC: none، وEPSS 1.0%). يُنصح بالترقية إلى 18.11.13 أو 19.0.10 أو 19.1.9 أو 19.2.9 أو 19.3.6 أو 19.4.3 أو 19.5.1 حسب الاقتضاء.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.11.13, 19.0.10, 19.1.9, 19.2.9; GitLab 18.11.13, 19.0.10, 19.1.9, 19.2.9. Check the vendor advisory for mitigations.

In the news

References

Get alerted when CVE-2026-110264 or the next vulnerability affects your stack