What’s Vulnerable › Vulnerabilities
CVE-2026-110310: RSA PKCS#1 v1.5 padding oracle via legacy envelope key format downgrade in Amazon S3 Encryption Client for .NET
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-16
- Weakness: CWE-204
Description
A remote user who can read encrypted objects in the S3 bucket can force a padding downgrade by altering the padding scheme recorded in an object's metadata to legacy PKCS#1 v1.5. Since this padding scheme is susceptible to the well-known Bleichenbacher attack, the user can use a PKCS#1 v1.5 padding oracle to recover the RSA-wrapped envelope key and decrypt the object. To remediate this issue, we recommend that users upgrade to version 3.2.2 or 4.0.3. The 1.x and 2.x lines will not be patched, users of those lines need to migrate to 3.2.2 or 4.0.3.
Affected products
- Amazon.Extensions.S3.Encryption: 2.x from 2.1.0; from 3.0.0 through 3.2.1; from 4.0.0 through 4.0.2
References
- https://aws.amazon.com/security/security-bulletins/2026-135-aws/
- https://github.com/aws/amazon-s3-encryption-client-dotnet/security/advisories/GHSA-322w-f6rw-r4fj
- https://www.nuget.org/packages/Amazon.Extensions.S3.Encryption/3.2.2
- https://www.nuget.org/packages/Amazon.Extensions.S3.Encryption/4.0.3
Get alerted when CVE-2026-110310 or the next vulnerability affects your stack