What’s Vulnerable › Vulnerabilities

CVE-2026-110450

Description

Nix before 2.35.3 and Lix before 2.95.4 allow privilege escalation via a repair operation because it could destroy and then replace a store path before content verification.

Affected products

How to fix

Upgrade to a fixed version: NixOS Nix 2.28.8, 2.30.6, 2.31.6, 2.34.9. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-110450 or the next vulnerability affects your stack