What’s Vulnerable › Vulnerabilities
CVE-2026-110635: webp-converter before 3.0.0 OS Command Injection via File Names and Options
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-26
- Weakness: CWE-78
Description
webp-converter before 3.0.0 contains an OS command injection vulnerability in src/webpconverter.js helpers that run libwebp binaries via execFile with shell enabled. Attackers controlling file names or option strings passed to cwebp, dwebp, gwebp, or webpmux functions can inject shell metacharacters to execute OS commands as the Node.js process.
Affected products
- scionoftech webp-converter: before 3.0.0 — fixed in 3.0.0
How to fix
Upgrade to a fixed version: scionoftech webp-converter 3.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/scionoftech/webp-converter
- https://github.com/scionoftech/webp-converter/blob/3729b65f1e904ab56b947ac3772020ce37a756c8/src/webpconverter.js#L41-L52
- https://github.com/scionoftech/webp-converter/blob/e09d963d772cae9ff6af63c268ca838ab334f861/CHANGELOG.md
- https://github.com/scionoftech/webp-converter/commit/f1b6724bc2e89f67ab05d51a854b4b1c5a99928a
- https://github.com/scionoftech/webp-converter/pull/53
- https://github.com/scionoftech/webp-converter/pull/53#issuecomment-5091652605
- https://www.vulncheck.com/advisories/webp-converter-before-3.0.0-os-command-injection-via-file-names-and-options
Get alerted when CVE-2026-110635 or the next vulnerability affects your stack