What’s Vulnerable › Vulnerabilities
CVE-2026-110690: Cloud Commander 19.20.2 through 19.21.1 Path Traversal via GET /api/v1/pack
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-26
- Weakness: CWE-23
Description
Cloud Commander (cloudcmd) versions 19.20.2 through 19.21.1 contains a path traversal vulnerability in the GET /api/v1/pack endpoint where the onGET handler at server/rest/index.js:130 calls the unguarded root() function instead of the root.resolve() validation wrapper used elsewhere. Attackers can send percent-encoded directory traversal sequences in the pack request path to read arbitrary files outside the configured --root directory, such as /etc/passwd or SSH private keys, which are archived and streamed back as a downloadable tar.gz file.
Affected products
- coderaiser cloudcmd: from 19.20.2 before 19.21.2 — fixed in 19.21.2
How to fix
Upgrade to a fixed version: coderaiser cloudcmd 19.21.2. Check the vendor advisory for mitigations.
References
- https://gist.github.com/mansurmavlankulov/5a0c4cbab8e49ac0669d126c854da95e
- https://github.com/coderaiser/cloudcmd/commit/91c024591f425e26200884d5e1d5ba972377968b
- https://github.com/coderaiser/cloudcmd/releases/tag/v19.21.2
- https://www.vulncheck.com/advisories/cloud-commander-through-path-traversal-via-get-api-v1-pack
Get alerted when CVE-2026-110690 or the next vulnerability affects your stack