What’s Vulnerable › Vulnerabilities
CVE-2026-110845: n8n before 1.123.83, 2.41.4, and 2.42.1 Code Execution via Git Node Log Operation
- Severity: high (CVSS 7.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-26
- Weakness: CWE-15
Description
n8n before 1.123.83, 2.x before 2.41.4, and 2.42.x before 2.42.1 contains a code execution vulnerability in the Git node Log operation, which fails to strip a repository's local git configuration before invoking an external program. Authenticated members who can point the node, including as an agent tool, at a repository whose local configuration they control can execute programs as the n8n process user.
Affected products
- n8n-io n8n: before 1.123.83; from 2.0.0 before 2.41.4; from 2.42.0 before 2.42.1 — fixed in 1.123.83, 2.41.4, 2.42.1
How to fix
Upgrade to a fixed version: n8n-io n8n 1.123.83, 2.41.4, 2.42.1. Check the vendor advisory for mitigations.
References
- https://github.com/n8n-io/n8n/security/advisories/GHSA-x8wx-g24x-3549
- https://www.vulncheck.com/advisories/n8n-before-1.123.83-2.41.4-and-2.42.1-code-execution-via-git-node-log-operation
Get alerted when CVE-2026-110845 or the next vulnerability affects your stack