What’s Vulnerable › Vulnerabilities
CVE-2026-110847: n8n before 1.123.83, 2.41.4, and 2.42.1 Stored XSS via Chat Trigger customCss Parameter
- Severity: high (CVSS 7.0 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-15
- Weakness: CWE-79
Description
n8n before 1.123.83, 2.x before 2.41.4, and 2.42.x before 2.42.1 contains a stored cross-site scripting vulnerability in the Chat Trigger hosted-chat page, where insufficiently sanitised customCss values are interpolated into the page as markup. Workflow authors can publish a chat without n8n user authentication whose payload executes on the instance origin, acting on the sessions of signed-in visitors.
Affected products
- n8n-io n8n: before 1.123.83; from 2.0.0 before 2.41.4; from 2.42.0 before 2.42.1 — fixed in 1.123.83, 2.41.4, 2.42.1
How to fix
Upgrade to a fixed version: n8n-io n8n 1.123.83, 2.41.4, 2.42.1. Check the vendor advisory for mitigations.
References
- https://github.com/n8n-io/n8n/security/advisories/GHSA-x5cw-hm7v-q7mj
- https://www.vulncheck.com/advisories/n8n-before-1.123.83-2.41.4-and-2.42.1-stored-xss-via-chat-trigger-customcss-parameter
Get alerted when CVE-2026-110847 or the next vulnerability affects your stack