What’s Vulnerable › Vulnerabilities
CVE-2026-110850: n8n before 2.41.4 and 2.42.1 Credential Check Bypass via Agent Node Parameters
- Severity: high (CVSS 7.2 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-15
- Weakness: CWE-863
Description
n8n before 2.41.4 and 2.42.0 before 2.42.1 does not validate credential ids stored in agent node parameters when an editor saves a shared workflow, because the check inspects only a node's credentials field. An editor can configure a Message an Agent node in inline mode with tools they control to resolve the owner's credentials and send decrypted secrets to an attacker-chosen destination.
Affected products
- n8n-io n8n: before 2.41.4; from 2.42.0 before 2.42.1 — fixed in 2.41.4, 2.42.1
How to fix
Upgrade to a fixed version: n8n-io n8n 2.41.4, 2.42.1. Check the vendor advisory for mitigations.
References
- https://github.com/n8n-io/n8n/security/advisories/GHSA-x25p-9mr6-cwgp
- https://www.vulncheck.com/advisories/n8n-before-2.41.4-and-2.42.1-credential-check-bypass-via-agent-node-parameters
Get alerted when CVE-2026-110850 or the next vulnerability affects your stack