What’s Vulnerable › Vulnerabilities
CVE-2026-110854: Parse Server before 8.6.97 and 9.10.2-alpha.6 Denial of Service via Unhandled Email Error
- Severity: high (CVSS 8.2 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-16
- Weakness: CWE-248
Description
Parse Server before 8.6.97 and 9.0.0 before 9.10.2-alpha.6 does not handle errors raised while sending verification or password reset emails, causing the server process to exit. A client holding only the public application keys can sign up, request a verification email, or request a password reset while the mail provider rejects, rate limits, or is unavailable, crashing the server.
Affected products
- parse-community parse-server: before 8.6.97; from 9.0.0 before 9.10.2-alpha.6 — fixed in 8.6.97, 9.10.2-alpha.6
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.97, 9.10.2-alpha.6. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/security/advisories/GHSA-46jj-qw3p-48fc
- https://www.vulncheck.com/advisories/parse-server-before-8.6.97-and-9.10.2-alpha.6-denial-of-service-via-unhandled-email-error
Get alerted when CVE-2026-110854 or the next vulnerability affects your stack