What’s Vulnerable › Vulnerabilities
CVE-2026-110857: GitPython before 3.2.0 Command Execution via ls_remote ext:: URLs
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-15
- Weakness: CWE-1287
Description
GitPython before 3.2.0 contains a remote code execution vulnerability that allows attackers to run commands because Git.ls_remote forwards URLs without check_unsafe_protocols validation. Attackers can supply ext:: remote-helper URLs to execute commands when git permits the ext transport, while merge_base and IndexFile.move also accept unguarded option injection.
Affected products
- Pypi Gitpython: before 3.2.0; 0.1.7, 0.2.0-beta1, 0.3.0-beta1, 0.3.0-beta2, 0.3.1-beta2, 0.3.2 (+109) — fixed in 3.2.0
- gitpython-developers GitPython: before 3.2.0 — fixed in 3.2.0
How to fix
Upgrade to a fixed version: Pypi Gitpython 3.2.0; gitpython-developers GitPython 3.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/gitpython-developers/GitPython/security/advisories/GHSA-w8jc-g24h-crhw
- https://www.vulncheck.com/advisories/gitpython-before-3.2.0-command-execution-via-ls-remote-ext-urls
Get alerted when CVE-2026-110857 or the next vulnerability affects your stack