What’s Vulnerable › Vulnerabilities
CVE-2026-110858: GitPython 3.1.30 before 3.2.0 Command Injection via Remote.pull() Refspec
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-16
- Weakness: CWE-88
Description
GitPython from 3.1.30 before 3.2.0 contains a remote code execution vulnerability in Remote.pull() whose unsafe-option guard inspects only keyword arguments, not the positional refspec. Attackers controlling the refspec can supply --upload-pack=<command> to execute OS commands as the calling process over local-path or SSH transports.
Affected products
- Pypi Gitpython: from 3.1.30 before 3.2.0; 3.1.30, 3.1.31, 3.1.32, 3.1.33, 3.1.34, 3.1.35 (+26) — fixed in 3.2.0
- gitpython-developers GitPython: from 3.1.30 before 3.2.0 — fixed in 3.2.0
How to fix
Upgrade to a fixed version: Pypi Gitpython 3.2.0; gitpython-developers GitPython 3.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/gitpython-developers/GitPython/security/advisories/GHSA-f9j4-qggq-h239
- https://www.vulncheck.com/advisories/gitpython-3.1.30-before-3.2.0-command-injection-via-remote-pull-refspec
Get alerted when CVE-2026-110858 or the next vulnerability affects your stack