What’s Vulnerable › Vulnerabilities
CVE-2026-110867: Renovate before 44.60.1 allowedEnv Allowlist Bypass via Shared Preset
- Severity: high (CVSS 8.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-16
- Weakness: CWE-863
Description
Renovate before 44.60.1 contains an allowlist bypass vulnerability that allows repositories to set restricted environment variables by placing env inside a shared preset. Attackers controlling an externally sourced preset can override variables like PATH, LD_PRELOAD, NODE_OPTIONS, or GIT_SSL_CAINFO in child processes on self-hosted instances.
Affected products
- mend-renovate-ce helm chart: before 15.5.0 — fixed in 15.5.0
- mend-renovate-enterprise-edition helm chart: before 10.5.0 — fixed in 10.5.0
- mend renovate-ce: before 15.5.0 — fixed in 15.5.0
- mend renovate-ee-server: before 15.5.0 — fixed in 15.5.0
- mend renovate-ee-worker: before 15.5.0 — fixed in 15.5.0
- renovatebot renovate: before 44.60.1 — fixed in 44.60.1
How to fix
Upgrade to a fixed version: mend-renovate-ce helm chart 15.5.0; mend-renovate-enterprise-edition helm chart 10.5.0; mend renovate-ce 15.5.0; mend renovate-ee-server 15.5.0; mend renovate-ee-worker 15.5.0; renovatebot renovate 44.60.1. Check the vendor advisory for mitigations.
References
- https://github.com/renovatebot/renovate/security/advisories/GHSA-6873-xr44-22vm
- https://www.vulncheck.com/advisories/renovate-before-44.60.1-allowedenv-allowlist-bypass-via-shared-preset
- https://github.com/nodemailer/nodemailer/security/advisories/GHSA-4g23-2xm8-66gc
Get alerted when CVE-2026-110867 or the next vulnerability affects your stack