What’s Vulnerable › Vulnerabilities
CVE-2026-110871: Nodemailer 3.0.0 before 10.0.10 Quadratic DKIM Header Unfolding Denial of Service
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-20
- Weakness: CWE-400
Description
Nodemailer from 3.0.0 before 10.0.10 contains a denial of service vulnerability in MessageParser.parseHeaders that allows users to exhaust CPU through quadratic header unfolding. Attackers can supply large recipient lists or long headers that fold into tens of thousands of continuation lines, blocking the Node.js event loop during DKIM signing.
Affected products
- nodemailer: from 3.0.0 before 10.0.10 — fixed in 10.0.10
How to fix
Upgrade to a fixed version: nodemailer 10.0.10. Check the vendor advisory for mitigations.
References
- https://github.com/nodemailer/nodemailer/security/advisories/GHSA-39m8-27wv-hr27
- https://www.vulncheck.com/advisories/nodemailer-3.0.0-before-10.0.10-quadratic-dkim-header-unfolding-denial-of-service
- https://github.com/nodemailer/nodemailer/security/advisories/GHSA-39m8-27wv-hr27
Get alerted when CVE-2026-110871 or the next vulnerability affects your stack