What’s Vulnerable › Vulnerabilities
CVE-2026-110873: Heym 0.0.55 before 0.0.121 Credential Theft via error_workflow_id Field
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-16
- Weakness: CWE-863
Description
Heym from 0.0.55 before 0.0.121 contains a privilege escalation vulnerability that allows shared collaborators to overwrite a workflow's error_workflow_id because the field is missing from OWNER_ONLY_EXECUTION_FIELDS. Attackers can point the error workflow to their own workflow with an HTTP node, and when the parent workflow errors the owner's decrypted credentials are injected and exfiltrated.
Affected products
- heymrun heym: from 0.0.55 before 0.0.121 — fixed in 0.0.121
How to fix
Upgrade to a fixed version: heymrun heym 0.0.121. Check the vendor advisory for mitigations.
References
- https://github.com/heymrun/heym/security/advisories/GHSA-c3f4-2mrj-jfqr
- https://www.vulncheck.com/advisories/heym-0.0.55-before-0.0.121-credential-theft-via-error-workflow-id-field
Get alerted when CVE-2026-110873 or the next vulnerability affects your stack