What’s Vulnerable › Vulnerabilities
CVE-2026-110938: JITServer: Multiple Denial of Service vulnerabilities via out-of-bounds heap reads during message and reply parsing
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-26
- Weakness: CWE-20
Description
In Eclipse OpenJ9 versions up to 0.63.0, the JITServer component is vulnerable to denial of service due to improper boundary checks during protocol message and reply handling. An unauthenticated remote attacker or malicious JITServer can transmit malformed network payloads that cause out-of-bounds heap reads, immediately crashing the JITServer daemon or client JVM process via a segmentation fault (SIGSEGV).
Affected products
- The Eclipse Foundation Eclipse OpenJ9: from 0.8.0 before 0.63 — fixed in 0.63
How to fix
Upgrade to a fixed version: The Eclipse Foundation Eclipse OpenJ9 0.63. Check the vendor advisory for mitigations.
References
- https://github.com/eclipse-openj9/openj9/pull/25011
- https://gitlab.eclipse.org/security/cve-assignment/-/work_items/407
- https://gitlab.eclipse.org/security/vulnerability-reports/-/work_items/943
- https://gitlab.eclipse.org/security/vulnerability-reports/-/work_items/944
- https://gitlab.eclipse.org/security/vulnerability-reports/-/work_items/946
- https://gitlab.eclipse.org/security/vulnerability-reports/-/work_items/947
Get alerted when CVE-2026-110938 or the next vulnerability affects your stack