What’s Vulnerable › Vulnerabilities
CVE-2026-110976: AI Engine < 3.7.9 - Editor+ Arbitrary Post Deletion via reject_media
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-18 · updated 2026-10-19
- Weakness: CWE-862
Description
The AI Engine WordPress plugin before 3.7.9 does not check that the item passed to one of its media actions belongs to the requesting user before converting it to an attachment and permanently deleting it, allowing users with the Editor role and above to delete arbitrary posts of any type, including content they cannot otherwise delete such as navigation menus, block templates and global styles.
Affected products
- AI Engine: before 3.7.9 — fixed in 3.7.9
How to fix
Upgrade to a fixed version: AI Engine 3.7.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-110976 or the next vulnerability affects your stack