What’s Vulnerable › Vulnerabilities
CVE-2026-110982: AI Engine < 3.8.6 - Editor+ Arbitrary Post Title and Excerpt Update via update_post_title and update_post_excerpt
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-21
- Weakness: CWE-862
Description
The AI Engine WordPress plugin before 3.8.6 does not check that the caller is allowed to edit the targeted object before updating its title and excerpt, allowing users with the Editor role and above to modify arbitrary posts of any type, including content they cannot otherwise edit such as navigation menus, block templates, global styles and WooCommerce coupons.
Affected products
- AI Engine: before 3.8.6 — fixed in 3.8.6
How to fix
Upgrade to a fixed version: AI Engine 3.8.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-110982 or the next vulnerability affects your stack