What’s Vulnerable › Vulnerabilities
CVE-2026-111041: AI Engine < 3.7.9 - Editor+ Arbitrary Post Modification via update_media_metadata and approve_media
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-18 · updated 2026-10-19
- Weakness: CWE-862
Description
The AI Engine WordPress plugin before 3.7.9 does not verify that the user performing certain AI media management actions owns or is otherwise allowed to edit the targeted object, allowing users with the Editor role or above to modify, or change the type of, arbitrary posts on the site, including content they are not permitted to edit.
Affected products
- AI Engine: before 3.7.9 — fixed in 3.7.9
How to fix
Upgrade to a fixed version: AI Engine 3.7.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-111041 or the next vulnerability affects your stack