What’s Vulnerable › Vulnerabilities
CVE-2026-111074: JITServer: Pre-authentication remote Denial of Service via integer overflow infinite loop in MessageBuffer::computeRequiredCapacity()
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-26
- Weakness: CWE-190
Description
In Eclipse OpenJ9 versions prior to 0.63.0, the JITServer component is vulnerable to a pre-authentication remote denial of service. When processing the initial 4-byte length field of an incoming TCP connection, an integer overflow in `MessageBuffer::computeRequiredCapacity()` causes the receiving compilation worker thread to enter an infinite loop consuming ~100% CPU. An unauthenticated remote attacker can exploit this by opening a small number of crafted TCP connections to exhaust the entire worker thread pool, silently halting compilation services for all connected client JVMs.
Affected products
- The Eclipse Foundation Eclipse OpenJ9: from 0.8.0 before 0.63 — fixed in 0.63
How to fix
Upgrade to a fixed version: The Eclipse Foundation Eclipse OpenJ9 0.63. Check the vendor advisory for mitigations.
References
- https://github.com/eclipse-openj9/openj9/pull/25008
- https://gitlab.eclipse.org/security/cve-assignment/-/work_items/422
- https://gitlab.eclipse.org/security/vulnerability-reports/-/work_items/940
Get alerted when CVE-2026-111074 or the next vulnerability affects your stack