What’s Vulnerable › Vulnerabilities
CVE-2026-111181: body-parser vulnerable to Denial of Service via trailing bytes after a compressed request body
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-22 · updated 2026-10-22
- Weakness: CWE-248
Description
body-parser is body parsing middleware for Node.js and Express. In versions before 1.20.9 and in versions from 2.0.0 before 2.4.0, a single request can crash any application using body-parser with default options. When a request carries a Content-Encoding such as gzip, body-parser pipes it into a decompression stream and, after reading the body, leaves that stream with no error listener. A payload of one valid compressed frame followed by trailing bytes decodes and the application responds normally, but the trailing bytes then reach the already-finished decoder, which emits an error that is re-thrown as an uncaught exception and terminates the process. No matching route is required because body parsing runs before routing, so any endpoint that parses a body is affected. The issue is fixed in body-parser 2.4.0 and 1.20.9, and users should upgrade to one of those versions or later. As a workaround, disable request-body inflation (set the body-parser inflate option to false) so encoded requests are rejected before any decompression stream is created.
Affected products
- Npm Body-Parser: from 2.0.0 before 2.4.0; before 1.20.9 — fixed in 2.4.0, 1.20.9
- body-parser: from 2.0.0 before 2.4.0; before 1.20.9 — fixed in 1.20.9, 2.4.0
How to fix
Upgrade to a fixed version: Npm Body-Parser 2.4.0, 1.20.9; body-parser 1.20.9, 2.4.0. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/expressjs/body-parser/security/advisories/GHSA-27r3-jxmh-p828
Get alerted when CVE-2026-111181 or the next vulnerability affects your stack