What’s Vulnerable › Vulnerabilities
CVE-2026-111381: FreeRDP before 3.32.0 Heap Buffer Overflow via Persistent Cache v2 Parser
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-10-16 · updated 2026-10-28
- Weakness: CWE-122
Description
FreeRDP before 3.32.0 contains a heap buffer overflow vulnerability in persistent_cache_read_entry_v2 that allows local attackers to corrupt heap memory via integer wraparound in bitmap size calculation. Attackers can craft a persistent cache v2 file with oversized width and height values that causes mismatched entry size accounting and fixed 16 KiB reads, leading to crashes or code execution when loaded.
Affected products
How to fix
Upgrade to a fixed version: FreeRDP 3.32.0; FreeRDP 3.32.0. Check the vendor advisory for mitigations.
References
- https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-26cc-wjh8-hjw6
- https://www.vulncheck.com/advisories/freerdp-before-3.32.0-heap-buffer-overflow-via-persistent-cache-v2-parser
- https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-26cc-wjh8-hjw6
Get alerted when CVE-2026-111381 or the next vulnerability affects your stack