What’s Vulnerable › Vulnerabilities
CVE-2026-111388: Frappe before 16.33.0 restrict_ip Allowlist Bypass via API Key, OAuth Authentication
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-16 · updated 2026-10-16
- Weakness: CWE-284
Description
Frappe Framework before 15.120.0 and 16.x before 16.33.0 does not enforce the per-user restrict_ip allowlist for non-session authentication methods, including API key, OAuth, and header-based authentication. Attackers holding valid credentials of these types can authenticate from IP addresses outside the allowlist, defeating the configured network-based access restrictions.
Affected products
- frappe: from 16.0.0 before 16.33.0; before 15.120.0 — fixed in 15.120.0, 16.33.0
How to fix
Upgrade to a fixed version: frappe 15.120.0, 16.33.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/frappe/security/advisories/GHSA-h9jq-7pgf-hw8q
- https://www.vulncheck.com/advisories/frappe-before-16.33.0-restrict-ip-allowlist-bypass-via-api-key-oauth-authentication
Get alerted when CVE-2026-111388 or the next vulnerability affects your stack