What’s Vulnerable › Vulnerabilities

CVE-2026-111497: Out-of-Bounds Write in Google Brotli Decoder

Description

A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream. Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.

Summary

CVE-2026-111497 is a critical out-of-bounds write in the Brotli decoder (c/dec/decode.c) affecting Google Brotli versions 1.0.3 through 1.2.0 on all platforms. A remote unauthenticated attacker can send a crafted Brotli-compressed stream to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code. The flaw is listed in CISA's Known Exploited Vulnerabilities catalog with active exploitation, and EPSS estimates a 36.0% probability of exploitation in 30 days. Update Brotli libraries and binaries to 1.0.10, 1.1.1, or 1.2.1, and follow CISA BOD 26-04 guidance, including evaluating internet exposure and applying forensics triage requirements.

CVE-2026-111497 هو ثغرة كتابة خارج الحدود (out-of-bounds write) حرجة في مفكك ترميز Brotli (الملف c/dec/decode.c) تؤثر على إصدارات Google Brotli من 1.0.3 حتى 1.2.0 على جميع المنصات. يستطيع مهاجم بعيد غير مصادق عليه إرسال تدفق Brotli مضغوط مصمم خصيصًا لإفساد ذاكرة حالة المفكك المجاورة، أو كشف محتويات ذاكرة حساسة، أو التسبب في حجب الخدمة، أو احتمال تنفيذ تعليمات برمجية عشوائية. الثغرة مدرجة في كتالوج CISA للثغرات المعروفة المستغلة مع استغلال نشط، وتقدّر EPSS احتمال الاستغلال خلال 30 يومًا بنسبة 36.0%. يجب تحديث مكتبات وبرامج Brotli إلى الإصدار 1.0.10 أو 1.1.1 أو 1.2.1، واتباع إرشادات CISA BOD 26-04 بما في ذلك تقييم التعرض للإنترنت وتطبيق متطلبات الفرز الجنائي.

Affected products

How to fix

Upgrade to a fixed version: Andybalholm Brotli 1.2.7; Anthropic Bun 1.4.4; envoyproxy envoy 1.37.8, 1.38.6, 1.39.3; Google Brotli 1.0.10, 1.1.1, 1.2.1; istio 1.29.9, 1.30.6, 1.31.2; Microsoft .NET 8.0.33, 9.0.22, 10.0.14; Node.js 22.23.4, 24.22.1, 26.12.1; Python-Hyper Brotlicffi 1.2.1.0; Pypi Brotli 1.2.1; Pypi Brotlicffi 1.2.1.0; Google Brotli 1.0.10, 1.1.1, 1.2.1. Check the vendor advisory for mitigations.

In the news

References

Get alerted when CVE-2026-111497 or the next vulnerability affects your stack