What’s Vulnerable › Vulnerabilities
CVE-2026-111664: Safing Portmaster before 2.2.5 Unauthenticated Forced Downgrade via /api/v1/updates/from-url
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-16 · updated 2026-10-21
- Weakness: CWE-306
Description
Safing Portmaster before 2.2.5 contains a missing authorization vulnerability that allows unprivileged local processes to force updates by calling the POST /api/v1/updates/from-url endpoint registered with api.PermitAnyone. Attackers can supply an attacker-controlled index URL that bypasses version checks and auto-apply settings, installing older Safing-signed releases carrying previously fixed vulnerabilities.
Affected products
- safing portmaster: before 2.2.5 — fixed in 2.2.5
How to fix
Upgrade to a fixed version: safing portmaster 2.2.5. Check the vendor advisory for mitigations.
References
- https://github.com/safing/portmaster/blob/v2.2.3/service/core/api.go#L145-L159
- https://github.com/safing/portmaster/commit/f943e1eaf98f45bc48490bf288e1d63c04929ae0
- https://github.com/safing/portmaster/issues/2292
- https://github.com/safing/portmaster/releases/tag/v2.2.5
- https://www.vulncheck.com/advisories/safing-portmaster-before-2.2.5-unauthenticated-forced-downgrade-via-api-v1-updates-from-url
Get alerted when CVE-2026-111664 or the next vulnerability affects your stack