What’s Vulnerable › Vulnerabilities
CVE-2026-111804: Apache Traffic Server: wasm plugin has a use-after-free and forwards unvalidated guest metric IDs
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-23
- Weakness: CWE-416
Description
Apache Traffic Server's experimental wasm plugin has a use-after-free in its transaction-close handler and forwards unvalidated guest-supplied metric IDs to the internal stats API. This issue affects Apache Traffic Server: from 10.0.0 through 10.1.4, 10.2.0. Users are recommended to upgrade to version 10.1.5 or 10.2.1, which fix the issue.
Affected products
- Apache Software Foundation Apache Traffic Server: from 10.0.0 through 10.1.4; 10.2.0
References
Get alerted when CVE-2026-111804 or the next vulnerability affects your stack