What’s Vulnerable › Vulnerabilities
CVE-2026-111808: Apache Traffic Server: HTTP/2 DATA frame padding underflow lets a client trigger backend worker-pool exhaustion
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-23
- Weakness: CWE-191
Description
Apache Traffic Server can be used to exhaust an HTTP/1.1 origin's worker pool via a malformed padded HTTP/2 DATA frame. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.15, from 10.0.0 through 10.1.4, 10.2.0. Users are recommended to upgrade to version 9.2.16, 10.1.5, or 10.2.1, which fix the issue.
Affected products
- Apache Software Foundation Apache Traffic Server: from 8.0.0 through 8.1.11; from 9.0.0 through 9.2.15; from 10.0.0 through 10.1.4; 10.2.0
References
Get alerted when CVE-2026-111808 or the next vulnerability affects your stack