What’s Vulnerable › Vulnerabilities
CVE-2026-111884: phpMyFAQ before 4.1.9 and 4.2.0-alpha before 4.2.0-beta Missing Current-Password Step-Up on E-mail Change Enables Account Takeover
- Severity: high (CVSS 8.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-17 · updated 2026-10-18
- Weakness: CWE-308
Description
phpMyFAQ before 4.1.9 and 4.2.0-alpha before 4.2.0-beta does not require the current password when changing an account e-mail in the user control panel (UserController::updateData, api/user/data/update), checking only the session and CSRF token. An attacker with a hijacked session can set the e-mail to their own mailbox and use the password-reset flow to take over non-2FA accounts, including superadmin.
Affected products
- thorsten phpMyFAQ: before 4.1.9; from 4.2.0-alpha before 4.2.0-beta — fixed in 4.1.9, 4.2.0-beta
How to fix
Upgrade to a fixed version: thorsten phpMyFAQ 4.1.9, 4.2.0-beta. Check the vendor advisory for mitigations.
References
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-7554-gx6g-xx77
- https://www.vulncheck.com/advisories/phpmyfaq-before-4.1.9-and-4.2.0-alpha-before-4.2.0-beta-missing-current-password-step-up-on-e-mail-change-enables-account-takeover
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-7554-gx6g-xx77
Get alerted when CVE-2026-111884 or the next vulnerability affects your stack