What’s Vulnerable › Vulnerabilities
CVE-2026-111885: phpMyFAQ 4.2.0-alpha before 4.2.0-beta Missing Authorization via deleteGroup API
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-17 · updated 2026-10-18
- Weakness: CWE-1220
Description
phpMyFAQ from 4.2.0-alpha before 4.2.0-beta contains a missing authorization vulnerability in GroupController::deleteGroup() that omits privilege-level checks on target groups. Authenticated non-SuperAdmin administrators holding GROUP_DELETE can send a crafted groupId to /admin/api/group/delete to permanently destroy higher-privileged groups and strip members' inherited rights.
Affected products
- thorsten phpMyFAQ: from 4.2.0-alpha before 4.2.0-beta — fixed in 4.2.0-beta
How to fix
Upgrade to a fixed version: thorsten phpMyFAQ 4.2.0-beta. Check the vendor advisory for mitigations.
References
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-crh2-cv2j-cpjh
- https://www.vulncheck.com/advisories/phpmyfaq-4.2.0-alpha-before-4.2.0-beta-missing-authorization-via-deletegroup-api
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-crh2-cv2j-cpjh
Get alerted when CVE-2026-111885 or the next vulnerability affects your stack