What’s Vulnerable › Vulnerabilities
CVE-2026-111888: phpMyFAQ 4.0.0 before 4.1.9 Incorrect Authorization via news update API
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-17 · updated 2026-10-18
- Weakness: CWE-863
Description
phpMyFAQ from 4.0.0 before 4.1.9 contains an incorrect authorization vulnerability that allows delegated admins lacking the editnews right to modify news by calling PUT /admin/api/news/update, which checks NEWS_DELETE instead of NEWS_EDIT. Attackers holding addnews and delnews can read the update-news CSRF token from their own cookie and rewrite any news item's header, body, author, link and active flag shown on the public front page.
Affected products
- thorsten phpMyFAQ: from 4.0.0 before 4.1.9 — fixed in 4.1.9
How to fix
Upgrade to a fixed version: thorsten phpMyFAQ 4.1.9. Check the vendor advisory for mitigations.
References
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-287v-6c6j-x9f7
- https://www.vulncheck.com/advisories/phpmyfaq-4.0.0-before-4.1.9-incorrect-authorization-via-news-update-api
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-287v-6c6j-x9f7
Get alerted when CVE-2026-111888 or the next vulnerability affects your stack