What’s Vulnerable › Vulnerabilities
CVE-2026-111891: phpMyFAQ from 4.2.0-alpha.2 before 4.2.0-beta Privilege Escalation via Group Permissions API
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-17 · updated 2026-10-19
- Weakness: CWE-269
Description
phpMyFAQ from 4.2.0-alpha.2 before 4.2.0-beta contains a privilege escalation vulnerability in the group permission API, whose updatePermissions and updateMembers endpoints check held rights without regard to language or category scope and write unrestricted group grants. Non-superadmin administrators holding GROUP_EDIT can grant a group a right they hold only in a narrow scope and self-join it via updateMembers, gaining unrestricted FAQ create, edit, and publish access across all languages and categories.
Affected products
- thorsten phpMyFAQ: from 4.2.0-alpha.2 before 4.2.0-beta — fixed in 4.2.0-beta
How to fix
Upgrade to a fixed version: thorsten phpMyFAQ 4.2.0-beta. Check the vendor advisory for mitigations.
References
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-6vf7-mrj2-7c37
- https://www.vulncheck.com/advisories/phpmyfaq-from-4.2.0-alpha.2-before-4.2.0-beta-privilege-escalation-via-group-permissions-api
Get alerted when CVE-2026-111891 or the next vulnerability affects your stack