What’s Vulnerable › Vulnerabilities
CVE-2026-111902: phpMyFAQ 4.2.0-alpha before 4.2.0-beta Authorization Bypass via Comments and Attachments API
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-17 · updated 2026-10-19
- Weakness: CWE-639
Description
phpMyFAQ 4.2.0-alpha before 4.2.0-beta contains an authorization bypass vulnerability in isFaqAccessibleForUser() that treats a missing FAQ translation as visible to unauthenticated users. Attackers can send a mismatched Accept-Language header to the comments and attachments API endpoints to read comments and attachment listings of unpublished or ACL-restricted FAQs.
Affected products
- thorsten phpMyFAQ: from 4.2.0-alpha before 4.2.0-beta — fixed in 4.2.0-beta
How to fix
Upgrade to a fixed version: thorsten phpMyFAQ 4.2.0-beta. Check the vendor advisory for mitigations.
References
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-g6fj-8cjr-wrxv
- https://www.vulncheck.com/advisories/phpmyfaq-4.2.0-alpha-before-4.2.0-beta-authorization-bypass-via-comments-and-attachments-api
Get alerted when CVE-2026-111902 or the next vulnerability affects your stack