What’s Vulnerable › Vulnerabilities
CVE-2026-111904: phpMyFAQ 4.2.0-alpha before 4.2.0-beta Information Disclosure via open-questions API
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-17 · updated 2026-10-18
- Weakness: CWE-200
Description
phpMyFAQ 4.2.0-alpha before 4.2.0-beta contains an information disclosure vulnerability that allows unauthenticated attackers to read hidden open questions due to an inverted api.onlyPublicQuestions check in OpenQuestionController. Attackers can send GET requests to the /api/v4.0/open-questions endpoint to retrieve non-public moderation or internal questions and their associated usernames.
Affected products
- thorsten phpMyFAQ: from 4.2.0-alpha before 4.2.0-beta — fixed in 4.2.0-beta
How to fix
Upgrade to a fixed version: thorsten phpMyFAQ 4.2.0-beta. Check the vendor advisory for mitigations.
References
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-6xm9-p734-8fx6
- https://www.vulncheck.com/advisories/phpmyfaq-4.2.0-alpha-before-4.2.0-beta-information-disclosure-via-open-questions-api
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-6xm9-p734-8fx6
Get alerted when CVE-2026-111904 or the next vulnerability affects your stack