What’s Vulnerable › Vulnerabilities
CVE-2026-111907: phpMyFAQ 4.0.0 before 4.1.9 CSRF via /admin/api/update-database
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-17 · updated 2026-10-19
- Weakness: CWE-352
Description
phpMyFAQ 4.0.0 before 4.1.9 contains a cross-site request forgery vulnerability in the POST /admin/api/update-database endpoint, which executes database migrations without validating a CSRF token. Attackers can lure a logged-in user with the CONFIGURATION_EDIT permission into submitting a crafted cross-site request, triggering migrations that may impact database integrity or availability.
Affected products
- thorsten phpMyFAQ: from 4.0.0 before 4.1.9 — fixed in 4.1.9
How to fix
Upgrade to a fixed version: thorsten phpMyFAQ 4.1.9. Check the vendor advisory for mitigations.
References
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-6x9g-rfx8-g42q
- https://www.vulncheck.com/advisories/phpmyfaq-4.0.0-before-4.1.9-csrf-via-admin-api-update-database
Get alerted when CVE-2026-111907 or the next vulnerability affects your stack