What’s Vulnerable › Vulnerabilities
CVE-2026-111908: phpMyFAQ 4.0.0 before 4.1.9 and 4.2.0-alpha before 4.2.0-beta BOLA in FAQ Update via REST API
- Severity: high (CVSS 8.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-17 · updated 2026-10-19
- Weakness: CWE-639
Description
phpMyFAQ 4.0.0 before 4.1.9 and 4.2.0-alpha before 4.2.0-beta contains a broken object-level authorization vulnerability in the PUT /api/v3.1/faq/update endpoint, which checks only the global edit_faq permission and does not verify access to the target FAQ. Authenticated users with edit_faq permission can supply the ID of a restricted FAQ they cannot view to modify its content, bypass moderation, and change its publication state.
Affected products
- thorsten phpMyFAQ: from 4.0.0 before 4.1.9; from 4.2.0-alpha before 4.2.0-beta — fixed in 4.1.9, 4.2.0-beta
How to fix
Upgrade to a fixed version: thorsten phpMyFAQ 4.1.9, 4.2.0-beta. Check the vendor advisory for mitigations.
References
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-j3px-r7cr-r26r
- https://www.vulncheck.com/advisories/phpmyfaq-4.0.0-before-4.1.9-and-4.2.0-alpha-before-4.2.0-beta-bola-in-faq-update-via-rest-api
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-j3px-r7cr-r26r
Get alerted when CVE-2026-111908 or the next vulnerability affects your stack