What’s Vulnerable › Vulnerabilities
CVE-2026-111909: phpMyFAQ before 4.1.9 Missing Authorization Allows Superadmin Deletion via deleteUser API
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-17 · updated 2026-10-18
- Weakness: CWE-269
Description
phpMyFAQ before 4.1.9 contains a missing authorization vulnerability in the deleteUser() API that allows authenticated non-superadmin users with delete_user permission to delete superadmin accounts. Attackers can send a DELETE request to /admin/api/user/delete with a superadmin's userId other than 1, removing administrative access and accountability.
Affected products
- thorsten phpMyFAQ: before 4.1.9 — fixed in 4.1.9
How to fix
Upgrade to a fixed version: thorsten phpMyFAQ 4.1.9. Check the vendor advisory for mitigations.
References
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-7j43-ww55-pm3g
- https://www.vulncheck.com/advisories/phpmyfaq-before-4.1.9-missing-authorization-allows-superadmin-deletion-via-deleteuser-api
Get alerted when CVE-2026-111909 or the next vulnerability affects your stack